RStudio IDE

CHEAT SHEET

Documents and Apps

Open Shiny, R Markdown,
ETEX | knitr, Sweave, LaTeX, .Rd files
and more in Source Pane

rmarkdown

Check  Render Choose Configure Insert
spellmg output output render code
- format opt|ons

Publish
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fis (Top Level) & R Markdown =

Access markdown guide at

Help > Markdown Quick Reference
See reverse side for more on Visual Editor

RStudio recognizes that files named app.R,
server.R, ui.R, and global.R belong to a shiny app

@] report.Rmd @ app.R @ script.R =l
Qz-lg 3 RunApp__v -l =

1T :
2T
3 Run  Choose™" Publishto - Manage
4
. app  location to shmyapps.lo publish
6 view app  orserver accounts
1:1 (Top Level) R Script ¢

Source Editor

Tab Panes

Version
memory lﬁtﬁu‘torials CO ntrOl

chunk  to server

Console  Terminal

R4.1.0 . ~/Desktop/app/

"POO30QOL!. ..........- Multiple cursors/column selection

"P0030002" .
"PO30003" with Alt + mouse drag.

"P0030004"

. Hover over diagnostic symbols for details.
get_digit <- functlon() {
("num" %% (10 A n))

Syntax highlighting based
on your file's extension

_Tab completion to finish function
fo names, file paths, arguments, and more.
D for {snippet} Fo;{g{l:variable} in ${2:vector}) {
¢ for {base} |k -
& force  {base} “Multi-language code snippets to

quickly use common blocks of code.

Jump to function in file

(Top Level) * R Séript 2

Code diagnostics that appear in the margin.

Change file type

R Markdown Jobs -

Navigate Openinnew Save Findand Compileas Run Importdata Historyof past Manage  View
backwards/ vvmdovv g replace notebook selected  with wizard commandsto  external
forvvards B code ; run/copy .databases usage -7
-| OBl | &~ = Go to file ffunction |5 - o .Ad'&ins ° R app ~
®+ report.Rpﬂd . GL app.R o] scrip,t:li. - Environm;‘qt Hi;tory Conn'e:;.tions B_l,lild""b“ Tutorial -
] Source on Save Q / - ’ "Rl‘lll"_""f _Source v T <yl s | ""Import Dataset ~ % 148 M|B ~ ;’ List ~ | (& ~
BoGood Start... e e - R'v ..'.j"(jl'éb'él'ii'ﬁ\'/ironment - i
Re-run =" SourceWith or Show file ¢ : : o
previous code  wjout Echo or outline Load Save ClearR Search inside | !
as a Local Job workspace : workspace workspace environment -

Choose envilonment to display from Display objects

list of parent environments as list or grid
Data
O df 3 obs. of 2 variables
Values
X 1
Functions
foo function (x)

Displays saved objects by Viewin'data View tu'ﬁetion

type with short description viewer source code
Files Plots Packages Help Viewer =
&New Folder € Delete =) Rename {a'More A G
Q Home  Desktop > app: z"PV'" Moré file R
A Name 5 5 opyTO- ; lodified $
: woe..  OptiONS
Create Delete Rena me Copy Folder Path to Clipboard Change’
Set As Working Directol .
folder : Efile file o T oo Oertony directory

Open New Terminal Here

Show Folder in New Window

Path to displayed directory

Package Development

Create a new package with
File > New Project > New Directory > R Package

Enable roxygen documentation with
Tools > Project Options > Build Tools

Roxygen guide at Help > Roxygen Quick Reference

See package information in the Build Tab

Run devtools::load_all()
and reload changes

Install package
and restart R

Environment H:jstory Connections  Build Git  Tutorial =
2] Install and Restart [/] Check  {k More ~
“ LTadA”d oo % Clear output
RunRCMD . Cleamand R and rebuild
Check Test Package 08T,
o [v] Check Package O®BE ) 3
CUStOm lZe Build Source Package RU n
package build Build Binary Package package
OpthI’lS -------------------- s Configure Build Tools... tests
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o i i i @ app.R Show Hidden Files |l 10, 2021, 6:21 PM
s :Working ™. Runscriptsin Maximize, R app.Rproj 3038 Jul 10, 2021, 4:51 PM
5 Director i inimi : : :
+3 y ,x“separate SESSIONS  MINIMIZE PANES )\ Liia browser keyed to your working directory.
ol 4 .-Ctrl/Cmd +arrews -y down  Drag pane Click on file or directory name to open.
> View(mtcars) up Build Lo boundaries
to see history . &
RStudio opens plots in a dedicated Plots pane RStudio opens documentation in a dedicated Help pane
Files Plots Packages Help Viewer ==l Files Plots Packages Help Viewer =0
p Zoom “5, Publish ~ @ DG4 Refresh Help Topic
. e R: RenderéMarkdown ~ | Find in Topic
Nawgate “Openin "~ Export Delete " Delete : o "
recent plots window plot plot all plots Home pageof  “Search within Search for
helpful links help file help file
Viewer pane displays HTML content, such as Shiny
GUI Package manager lists every installed package apps, RMarkdown reports, and interactive visualizations
Files Plots Packages Help Viewer = =]
Files Plots Packages Help Viewer P o o 2, %, Publish ~
ol Ipstall @ Update e O
jhame  *. | Description ersion Stop Shiny Publish to shinyapps.io Refresh
Install Update Browse app rpubs, RSConnect, ...
Packages Packages package site
tibble Simple Data Frames 3.1.2 -
£ Tidy Messy Data =2 : View(<data>) opens spreadsheet like view of data set
Click to load package with Package  Delete e = lwe e ¢l f e :
Iibrary() UnClle to detaCh VerSlon from Mazda Rx,l4 mngl.O ” 6 ISIPGO.O pll() ra3590 V;.GZO qse1c6.4(5 vs 0 . 1
paCkage Wlth detaCh() lnStalled llbrary MazdaRX4Wa:g 21.0 6 160.0 110 3590 2.875 17.02 0 1
Filter rows by value Sort by Search
orvalue range values forvalue

Turn on at Tools > Project Options > Git/SVN

¢ ™ Added @@ Modified
G B Deleted @ Renamed ? Untracked
Stage  Commit Push/Pull  View  Current

files: staged files to remote

En‘('ironmem Hlstory Conr!ecnons By}|d-v"(2|t Tutorial -
='oiff = v Commit - o {a' - Za (o branch) ~ -
Staged: Status = Path K
[ .gitignore

W Bm apr Open shell to type commands

Show file diff to view file diﬁerences

Changes | History | (nobranch) ~ (= v Stage = % Revert () Ignbre
Staged Status - Path Commit message
0 gitignore :
] R B
U B0 ap : Amend previous ommit T ——
O app.Rproj .
Show () Staged © Unstaged  Context [ 5lines #)  Ignore Whitespace  «| Stage All = [5] Discard All

@@ -1,13 +1,11 e@ Stage chunk | Discard chunk

i #
2 # This is a Shiny web application. You can run the application by clicking

Debug Mode

Use debug(), browser(), or a breakpoint and execute
your code to open the debugger mode.

Launch debugger ~ Open traceback to examine
mode from origin  the functions that R called
of error ) before the error occurred
Console  Terminal ""jo..bs —=
> helloQ) ;
Error 2" Show Traceback
" & Rerun with Debug

Click next to line number to
add/remove a breakpoint.

Highlighted line shows where
execution has paused

) painarome.t 01| fottommen Moy | bula G B

7 p'tnmmu whether a positive number is a palindrome  .** B palindrome0~
& palindrome <- function(num) { . Values

®'9 | digits < floor(log(num, 10)) + 1 digitl [
10~ for (x in 1:((digits %/% 2)) { digits 5
1 digitl < get_digit(num, x) - 0000
»12 digit2 <- get_digit(num, (digits + 1 - x) nun 1 o
13 if (digitl |- digit2) = t

14 return(FALSE)

1
16 return(TRUE)
17}

Araceback Show internals =
# palindrome(candidate) at palindrome.R:12

I biggest_palindrome() at palindrome.R:25

Rsarpt £ |+ B

19 # Find the largest palindrome that is the product of two 3-dig
_palindrome <- function() {

(num%%(lﬂ n))%/%(lﬂ (n - 1)) I Fles Plots Packages Help Viewer =0
I QiNewFoider O uplosd © n
Browse[3]> 2 | % Home  iEcheushert ¥
debug at ~/RStudio-Essentials/Essentials-2/palindrome.R#12: d\g\tZ e
- get_digit(num, (digits + 1) - x) B
smwseth . ;' ) appR 12K8%  Dec24,2015,9:05 AM
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Run commands in Examine variables  Select function

environment where in executing in traceback to

execution has paused  environment debug
Console  Terminal Jobs =[]
= Next {“} g— p Continue [l Stop

Step through Step into and Resume QlJlt debug

codeoneline outoffunctions  execution mode
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Keyboard Shortcuts RStudio

RUN CODE Windows/Linux Mac DOCUMENTS AND APPS Workbench
Search command history Ctrl+arrow-up  Cmd-+arrow-up Knit Document (knitr) Ctrl+Shift+K Cmd+Shift+K
Interrupt current command Esc Esc Insert chunk (Sweave & Knitr) ~ Ctrl+Alt+ Cmd+Option+l WHY RSTUDIO WORKBENCH?
Clear console Ctrl+L Ctrl+L Run from start to current line  Ctrl+Alt+B Cmd+Option+B Extend the open source server with a
commercial license, support, and more:

NAVIGATE CODE MORE KEYBOARD SHORTCUTS _ _
Go to File/Function Ctrl+. Ctrl+. Keyboard Shortcuts Help Alt+Shift+K Option+Shift+K + open and run multiple R sessions at once
WRITE CODE Show Command Palette Ctrl+Shift+P Cmd+Shift+P » tune your resources to improve performance

co . « administrative tools for managing user sessions
Attempt completion Tab or Tab or lab i ith others in shared proi

Ctrl+Space Ctrl+Space View the Keyboard Shortcut Quick Search for keyboard shortcuts with » collaborate real-time with others in shared projects
. . Reference with Tools > Keyboard Tools > Show Command Palette « switch easily from one version of R to a different version
Insert <- (assignment operator) Alt+- Option+- Shortcuts or Alt/Option + Shift + K or Ctrl/Cmd + Shift + P. ) .y L o . :
Insert %>% (pipe operator) Ctrl+Shift+M Cmd+Shift+M « integrate with your authentication, authorization, and audit practices
(Un)Comment selection Ctrl+Shift+C Cmd+Shift+C Rl e e H | « work in the RStudio IDE, JupyterlLab, Jupyter Notebooks, or VS Code
Tabs Source Navigation

MAKE PACKAGES Windows/Linux Mac - o, ‘ izl Sl Cernienl i Senote Download a free 45 day evaluation at
Load All (devtools) Ctrl+ShiftsL Cmd+Shift+L . eios . - Create a New R Script (cert] (i) (1) www.rstudio.com/products/workbench/evaluation/

Test Package (Desktop) Ctrl+Shift+T Cmd+Shift+T Create a new R Markdown document

Document Package Ctrl+Shift+D Cmd+Shift+D . j et S h are P rOJ S CtS

1 Move Focus t Go To Fil
2 Move Focus to Console oo

File > New Project
RStudio saves the call history,

V. l E d . Workspace, and vvorking Start new R Session Close R Session
| S u a |to r Choose Choose Insert Jumpto Jump  Run directory associated with a in current proiect . in project
! . ) proj . proj
Check  Render  output output code previous tonext selected Publish Show file project. It reloads each when o .
spelling output  format location chunk chunk  chunk lines toserver  outline you re-open a project. BEE et G | sessions & ®
: ; o T : Back to . ‘
@J report.Rmd = | . Source Editor S IDEch.eatsheet- R3.2.2 -
Block - P . : : : 47 (front page @ New Project... : : ¥ Rversior 3.2.2
format ; 2 V4 Q & Knit  ~ v +@ v = Run -~ ".:J' v < bag ) 2 Open Project... ?gltll\a/gglr’]aatgerg : R version': 3.1.3
.................. Heading 2 ~ B I U <« ¥« @ B Format ~ |Insert ~ Table ~ Close Project : ' Ryversior: 3.0.3
) : . . . - : " -~ (& Share Project... : Name of R version:2.15.3
: - : ’ I RMarkdown File outline IDEcheatsheet ‘, current
- Lists and e L . |nCIUding Plots RStudio-Essentials ; projeCt )
; : Links Citations Images .. :
t'|_t'|_e . "Document T1t]_e" blOCk g |ﬂsert blOCkS, Essentials 7 : . ge\;:::ion
author: "Author Name-'n : qUOteS More Cltathns? ~Insert and shiny-examples T ~ Share Project
) i formatting ~ equations,and edit tables Clear Project List with Collaborators
OUtpUt : Clear . SpeC|al Project Options... 8,
html_document: @ formatting characters
toc: TRUE  Insert.
verbatim
code Run Remote Jobs
{r setup, include=FALSE} 4 Run R on remote Clusﬁers 1 e -
knitr: :opts_chunk$set(echo = TRUE) (Kubernetes/Slurm) via the o Source oS
JOb Launcher Source with Echo 0¥
........... Add/EC“t .{ Source as Launcher Job...
R Markdown attributes Monitor Launchajob = 3 Source as Local Job..
auncheriobs...
ThlS Is an R Markdown document' Console  Terminal Jobs ..L5imcher -]
Markdown is a Simple formatting Run this and 4 Start Launcher Job | {3k Sorted by submission time ~
syntax for authoring HTML, PDF, Setknitr  all previous . . ,
and MS Word documents chunk — code chunks bR running roca e @
' options :
° : Run this sleepy.R Succeeded 11:22 AM Local 0:41 >
Jump to chunk {r cars} T P code chunk
or he?der summary(cars) sleepy.R dle KubernetesX  Waiting @ O
/[ R Markdown = R Markdown = Run launcher

jobs remotely
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